ARO 10-0 help needed

Presentations,questions,everything...only in english language,please

Moderator: UMMM461

Post Reply
Tht30
Nou venit
Nou venit
Posts: 3
Joined: 06 Jul 2019, 15:57

ARO 10-0 help needed

Post by Tht30 » 08 Jul 2019, 16:47

Hello there,
New comer to this forum, I have been the happy owner since 2014 of an ARO 10, first model, with individual wheel suspension on the rear axle.
I recently found myself in deep trouble, as I broke a rear transmission shaft : I can't remove the broken shaft from its place, even after lowering the triangle at the lowest point. As I don't have any repair manual, I have no idea how to manage : remove the suspension triangle, or detach the differential box, or else ?
Any suggestion ? By the way, it would be great if someone could post the relevant tech manual !
Thanks for your help


User avatar
George
Administrator
Administrator
Posts: 6811
Joined: 11 Dec 2006, 21:18
Location: Bucuresti
Contact:

Re: ARO 10-0 help needed

Post by George » 19 Nov 2019, 14:24

Hello!
Where is the shaft blocked? In the wheel hub? At bearing wheel?
If it's blocked there, you must spray rust remover, brake liquid or diesel, to unblock. It is possible to be forced to use hydraulic press.
ARO CLUB ROMANIA

User avatar
ardeleanu
Membru legendar
Membru legendar
Posts: 2430
Joined: 16 Jun 2014, 10:11
Location: Choisy le Roi, Franta

Re: ARO 10-0 help needed

Post by ardeleanu » 19 Nov 2019, 20:30

Hi,
Just drop an email to Thierry Thouaille ( from France, but he is speaking english...), thierry.thouaille @ gmail. com
He had the same issue a few weeks ago and he can provide you some technical advices.
Good luck!


Post Reply